Ecommerce software home
Shopping Cart Software Forum for Ecommerce Templates
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?



Find us on Facebook

Follow us on Twitter

View our YouTube channel


 All Forums
 General
 Off topic, News and Updates
 SSL
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic   

mediator
Ecommerce Template Expert

United Kingdom
648 Posts

Pre-sales questions only
(More Details...)

Posted - 09/11/2019 :  07:03:49  
Hi, I have set up an SSL and it has switched over on the site and is now showing the green padlock.

I have just had an email confirmation of an order from Worldpay of a regular customer, but if I look on the admin it's showing the order in red and the authorize button next to the order! I have also not had the site auto-confirmation email

any ideas?

dbdave
ECT Moderator

USA
8064 Posts

Posted - 09/11/2019 :  08:42:24  
It may be that you need to check settings for Worldpay to see if any info passed back to your site is failing due to the SSL changes.
I must admit I am not familiar with Worldpay (others here are though, I am sure), but that's where I would look first.
If the setup requires a URL to your site, then check to see if it needs to be updated to https perhaps.

David

1818charlie
Advanced Member

United Kingdom
333 Posts

Pre-sales questions only
(More Details...)

Posted - 09/11/2019 :  10:28:32  
Check your online WorldPay account that all the links to your site are https.

Steve
Manchester, UK.

Edited by - 1818charlie on 09/11/2019 10:30:52

mediator
Ecommerce Template Expert

United Kingdom
648 Posts

Pre-sales questions only
(More Details...)

Posted - 09/23/2019 :  09:32:24  
Ok site is redirecting after SSL to https://www.snuff.me.uk/

The redirects look like this <http://snuff.me.uk/> ---> <https://snuff.me.uk/> <http://www.snuff.me.uk/> ---> <https://www.snuff.me.uk/> <https://snuff.me.uk/> ---> <https://snuff.me.uk/> <https://www.snuff.me.uk/> ---> <https://www.snuff.me.uk/>



But on the Seo reports its still saying im not redirecting properly and need to decide whether you prefer the <https://www> or the https:// non-www

how and where do i do this ?

Cheers
Jamie

Sinbad
Administrator

65733 Posts

Posted - 09/23/2019 :  10:52:52  
Hi Jamie, have a look at the post here by dbdave that should point you in the right direction https://www.ecommercetemplates.com/support/topic.asp?TOPIC_ID=106851

Winners never quit, quitters never win
CSS and Responsive Designs
User Manual for Ecommerce Templates

mediator
Ecommerce Template Expert

United Kingdom
648 Posts

Pre-sales questions only
(More Details...)

Posted - 09/24/2019 :  01:26:34  
i have but im still unsure what i need to add on the rule to help my issues im having

Vince
Administrator

38048 Posts

Posted - 09/24/2019 :  04:47:28  
Hi Mediator,
If you have a rule forcing the site onto HTTPS (which is good) you have to make sure your Payment Response URL is set to HTTPS. For instance...

With your Ecommerce Plus template, in the vsadmin directory, you will notice that you have a file called wpconfirm.asp. You want to set the "Payment Response URL" to point to this file. So for instance it might be . . .
https://www.yourstoreurl.com/vsadmin/wpconfirm.asp

Otherwise when WorldPay hits the wpconfirm.asp page it is redirected and the POST parameters are lost.

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater
   Topic   
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Shopping Cart Software Forum for Ecommerce Templates © 2002-2019 ecommercetemplates.com
This page was generated in 0.02 seconds. Snitz Forums 2000