Ecommerce software home
Shopping Cart Software Forum for Ecommerce Templates
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?



Find us on Facebook

Follow us on Twitter

View our YouTube channel


 All Forums
 Technical
 WordPress for Ecommerce Templates
 jQuery.fn.live
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic   

JustDucky923
Ecommerce Template Guru

USA
1239 Posts

Posted - 09/01/2020 :  08:50:08  
Sorry if this is the wrong place to ask this question but I'm getting a little desperate. It's not specifically ECT related (although it is happening on my ECT sites as well as non-ECT sites) - I'm looking for someone with knowledge of this type of issue and willing to pay someone to help me fix it. Since everyone I've worked with on this site has always been so helpful and knowledgeable - I thought I'd give it a try.

Here's the issue:

- I have about 68 WordPress site (about 5 currently using ECT)
- Over this past weekend I upgraded them all to WP 5.5
- At first glance everything seemed to look fine
- I also use a plug in called SiteOrigin Page Builder (great plugin by the way, have been using it for years)
- I discovered yesterday that although the plugin was still there - when I open any page to edit or add, the page builder was gone.
- I tried deactivating all non SiteOrigin plugins - that did not fix anything.
- I tried activating the basic 2020 WP theme instead of my custom theme - that worked.
- All of these sites have been created uwith custom themes using a program called Artisteer.
- It seems the theme is what's causing the problem.
- Through a bunch of Google searching I found a plug in called "Enable jQuery Migrate Helper"
- As soon as I installed that plugin and activated it - the problem was fixed.
- That plugin is just a work around and it shows you what is causing the issue.
- The warning that is showing on all of WP editor pages is: jQuery.fn.live() is deprecated
- Through some more Google searching it seems that the new version should be "jQuery.on" -- or something like that.
- I've searched through all of the WP files in the theme and I can't find any instance of ".live" anywhere.

Here's what I'm looking for:

- Someone who understands what I've explained (I'm sure I'm missing some things).
- Someone who knows how, or even has some ideas on how to fix this issue.
- Someone who is willing to help me out of this mess.

As I said, I have 68 of these sites - I can't just remove their custom themes, and to rebuild 68 themes is giving me a migraine just thinking about it!

Anyone?

Sinbad
Administrator

65850 Posts

Posted - 09/01/2020 :  15:14:15  
Hi Kelly, Sounds like the plug-in is not compatible with 5.5 it would be best to contact the theme developer on this Seems they already have several post regarding the 5.5 update

https://siteorigin.com/thread/site-origin-page-builder-not-working-after-latest-wp-update/
and here
https://siteorigin.com/thread/page-builder-issues-after-wp-5-5-update/
and this one
https://siteorigin.com/thread/page-builder-dont-work-with-artisteer-theme-wp-5-5/

Winners never quit, quitters never win
CSS and Responsive Designs
User Manual for Ecommerce Templates

JustDucky923
Ecommerce Template Guru

USA
1239 Posts

Posted - 09/02/2020 :  08:56:46  
It's not the plugin that is causing the error, it is the theme. The theme is a custom theme that I created using Artisteer. It seems that it it s the jQuery.fn.live() in the theme that is causing this problem.

If I switch to a basic WP theme the problem goes away.

The problem is almost all of my sites are using custom themes that I created over the past several years using Artisteer. No one is answering anything over at Artisteer.

I just posted another thread on here because one of my ECT sites is now showing a bunch of different errors.

JustDucky923
Ecommerce Template Guru

USA
1239 Posts

Posted - 09/02/2020 :  10:02:59  
I've been reading a lot of forums the past few days. It seems that this upgrade to 5.5 caused a ton of sites to "break". Apparently it has effected over 2,500 plugins and tons of themes that used older jQuery.

I know that it is my theme that needs to be fixed, but I don't know how to do it. This is why I put out this desperate call for help. I'm willing to pay anyone that can figure out a way to get into the code of my theme and fix this and let me know how to move forward without this continuing to happen.

It seems that Artisteer and their parent company Extensoft are out of business - they don't answer any emails and their phone numbers are all disconnect.

I'm in a real mess here.

Sinbad
Administrator

65850 Posts

Posted - 09/02/2020 :  10:42:51  
Hi Kelly, WP 5.5 did cause a lot of havoc and WP has issued a patch 5.5.1 so that theme developers can get their themes and plug-ins up-to date.
It would be better to post in the developer forum where they will see it, or try one of the free lance sites where tons of WP devs hang out, just check their credentials are good ask a lot of questions before payment and it they promise you the moon and world run to one that just promises to get the job done in a timely fashion.
quote:
I'm willing to pay anyone that can figure out a way to get into the code of my theme and fix this and let me know how to move forward without this continuing to happen.


The update did affect one of my ect WP sites but it was just a matter of reinstalling the mis-behaving plug-in and re-registering it with the author as the API broke on the 5.5 upgrade and needed a new key. Overall the features added to 5.5 are pretty good (except the editor) never liked Gutenberg editor prefer other editors. The auto update for the plugins is sweet.

Winners never quit, quitters never win
CSS and Responsive Designs
User Manual for Ecommerce Templates

JustDucky923
Ecommerce Template Guru

USA
1239 Posts

Posted - 09/02/2020 :  10:49:19  
Thanks, I will do that.

The 5.5.1 update did not fix the issue at all. They only work around right now, that everyone is using is to install the plugin "Enable jQuery Migrate Helper" -- it will make everything work and show you an error that explains the conflict.

That is where I'm at right now, I have the error, I know it's from my template and I need to figure out how to fix it.

I've heard that the update even made it impossible to upload images to any sites. What a mess!
   Topic   
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Shopping Cart Software Forum for Ecommerce Templates © 2002-2019 ecommercetemplates.com
This page was generated in 0.03 seconds. Snitz Forums 2000