Ecommerce software home
Shopping Cart Software Forum for Ecommerce Templates
 
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


Find us on Facebook Follow us on Twitter View our YouTube channel
Search our site

 All Forums
 Developers, Mods and Updaters
 PHP Mods
 Problem with WP theme - willing to pay for help
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic   

JustDucky923
Ecommerce Template Guru

USA
1241 Posts

Posted - 09/02/2020 :  10:57:26  
Sorry if this is the wrong place to ask this question but I'm getting a little desperate. It's not specifically ECT related (although it is happening on my ECT sites as well as non-ECT sites) - I'm looking for someone with knowledge of this type of issue and willing to pay someone to help me fix it. Since everyone I've worked with on this site has always been so helpful and knowledgeable - I thought I'd give it a try.

Here's the issue:

- I have about 68 WordPress site (about 5 currently using ECT)
- Over this past weekend I upgraded them all to WP 5.5
- At first glance everything seemed to look fine
- I also use a plug in called SiteOrigin Page Builder (great plugin by the way, have been using it for years)
- I discovered yesterday that although the plugin was still there - when I open any page to edit or add, the page builder was gone.
- I tried deactivating all non SiteOrigin plugins - that did not fix anything.
- I tried activating the basic 2020 WP theme instead of my custom theme - that worked.
- All of these sites have been created uwith custom themes using a program called Artisteer.
- It seems the theme is what's causing the problem.
- Through a bunch of Google searching I found a plug in called "Enable jQuery Migrate Helper"
- As soon as I installed that plugin and activated it - the problem was fixed.
- That plugin is just a work around and it shows you what is causing the issue.
- The warning that is showing on all of WP editor pages is: jQuery.fn.live() is deprecated
- Through some more Google searching it seems that the new version should be "jQuery.on" -- or something like that.
- I've searched through all of the WP files in the theme and I can't find any instance of ".live" anywhere.

Here's what I'm looking for:

- Someone who understands what I've explained (I'm sure I'm missing some things).
- Someone who knows how, or even has some ideas on how to fix this issue.
- Someone who is willing to help me out of this mess.

As I said, I have 68 of these sites - I can't just remove their custom themes, and to rebuild 68 themes is giving me a migraine just thinking about it!
   Topic   
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Shopping Cart Software Forum for Ecommerce Templates © 2002-2020 ecommercetemplates.com
This page was generated in 0.02 seconds. Snitz Forums 2000