Ecommerce software home
Shopping Cart Software Forum for Ecommerce Templates
 
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


Find us on Facebook Follow us on Twitter View our YouTube channel
Search our site

 All Forums
 Technical
 ASP (Windows server) versions
 Won't Complete Transaction
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author  Topic 
Page: of 2

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/19/2020 :  09:39:34  
Our shopping cart has worked properly for several years. Recently, when a customer goes to make a purchase, the transaction won't finish. When the checkout button is clicked for the final step of the transaction, the wheel just spins and never completes the transaction. Also when we go to our Ecommerce admin site. When we click on any of the menu items, it does the same thing. Just spins.

Vince
Administrator

39851 Posts

Posted - 12/19/2020 :  09:54:58  
Hi there
Could you let us know the store URL so that we can give it a go?

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/19/2020 :  19:20:32  
Hi Vince,

Thanks for your reply. The website is www.theherbprof.com.

Sample product; https://www.theherbprof.com/proddetail.asp?prod=hfeart01.

Shopping cart url: https://www.theherbprof.com/cart.asp

Ken

Vince
Administrator

39851 Posts

Posted - 12/20/2020 :  01:27:08  
Hi Ken
I had a go through checkout and I get...
An error occurred during processing. Call Merchant Service Provider.
It may be worth calling Authorize.net to ask them if they know what the problem is.
Authorize.net did update their AIM API and we've integrated the new version into the cart, but by the looks of things you have updated recently and would have the new version, no?

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/20/2020 :  14:40:48  
Hi Vince,

I logged on to Authorize.net and found your transaction. I also found two other transaction that followed yours. One was declined and one was captured.

I'm not sure what to make of this. It would appear that all of a sudden the cart is working again.

I think I'll test it by making a purchase and seeing what happens.

Thanks again for your help.

Ken

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/27/2020 :  11:54:57  
The same problem is happening again. Cart just spins on checkout. Same with the ecommercetemplate admin site. It doesn't fill in recent orders on the top part of the home page. Also when clicking on link, like Product Admin. It also just spins.

Vince
Administrator

39851 Posts

Posted - 12/27/2020 :  14:48:03  
Hi Ken
Would the first step then be to update the cart to one of the latest supported versions to make sure you have the latest Authorize.net changes?
https://www.ecommercetemplates.com/updaters.asp

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/27/2020 :  17:17:14  
I'll try that. Thanks.

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/28/2020 :  12:30:03  
The updater appears to have solved the problem. The cart is working now. Hopefully it continues to operate correctly. Thanks again for your help.

Vince
Administrator

39851 Posts

Posted - 12/28/2020 :  13:51:32  
Hi Ken
Ok, then it seems you may have been on the old AIM integration and Auth.net must be starting to shut that down. Updating automatically updates AIM to the new API.

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/29/2020 :  09:35:59  
After the update, the cart worked for my test order and one order came in this morning. Shortly after that someone attempted to place a order and it never completed, came in as unauthorized. I tried to place an order shortly after that one and it did the same. It just spun and after I closed the screen, I checked the admin site and it also showed as unauthorized.

kwhiteing
Starting Member

USA
18 Posts

Posted - 12/29/2020 :  11:01:01  
I tried again to place an order, after waiting for about 1 1/2 hours and was able to complete a new order.

Could it be a problem of the database being tied up and not able to process because another user has it tied up?

Vince
Administrator

39851 Posts

Posted - 01/02/2021 :  02:43:23  
Updating the database for a completed transaction is nothing really in terms of processing time so I doubt very much it's that. What I'm starting to think it might be is that there are intermittent problems with the SMTP server. Could you possibly try sending a few emails with the Email Friend function and see if that does anything similar?

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/05/2021 :  18:00:09  
Thanks again for the response. I couldn't find anywhere on our site where we use the email friend function. Should I try to change the coding to put it on some of the pages, so I can try sending emails as you suggested?

Also just an update to what's happening with the cart. It's now giving this error message: Error, couldn't connect to https://api.authorize.net/xml/v1/request.api (-2147012894). The operation timed out.

Vince
Administrator

39851 Posts

Posted - 01/06/2021 :  02:32:57  
quote:
It's now giving this error message: Error, couldn't connect to https://api.authorize.net/xml/v1/request.api (-2147012894). The operation timed out.
Can you ask your host then if they have a firewall or anything else that would block access to that URL. Also, can you go to the admin dashboard and right at the bottom there should be a section of Debugging Info, and let me know what you have there for the Server Software.

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/06/2021 :  15:34:08  
The Server Software is Microsoft-IIS/10.0

Vince
Administrator

39851 Posts

Posted - 01/07/2021 :  12:48:43  
quote:
Can you ask your host then if they have a firewall or anything else that would block access to that URL.
Ok, the server software is up to date so there shouldn't be any problem with the security protocols. Please let us know what the host comes back with as there seems to be something blocking connection to that URL.

Vince

Click Here for Shopping Cart Software
Click Here to sign up for our newsletter
Click Here for the latest updater

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/07/2021 :  12:48:57  
Contacted Authorize.net. They suggested trying to change the Transaction Key. I did that and it didn't change anything.

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/07/2021 :  13:03:53  
I also contacted the webhost, Startlogic again. As usual, the first contact has to escalate it further. That takes at least 24 hours.

This is at least the third time that I contacted them on this issue.

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/08/2021 :  09:25:56  
This is the reply that I received from webhost Startlogic.

"I was able to replicate the issue after adding the product to the cart and then trying to checkout. I received the below message:

I'm sorry, there was a problem with your transaction.
Error, couldn't connect to https://api.authorize.net/xml/v1/request.api (-2147012894).
The operation timed out

I confirmed that there is no issue with connecting Authorize.Net API through our Windows server. It might be an issue with the Authorize.Net payment gateway. Could you please confirm that your Authorize.Net account is setup to accept orders from your website https://www.theherbprof.com ? Also, correct details are updated on your store website to connect Authorize.Net API? If this problem has started recently, please let us know when the date since when you experiencing this issue."

kwhiteing
Starting Member

USA
18 Posts

Posted - 01/08/2021 :  10:05:07  
Talked again with authorize.net.
This value: https://api.authorize.net/xml/v1/request.api is the production api endpoint.
The numbers in parenthesis following doesn't match any of their error codes.

They said I should make sure that the endpoint value matches in our coding. Not sure where to find that.
Page: of 2  Topic   
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Shopping Cart Software Forum for Ecommerce Templates © 2002-2020 ecommercetemplates.com
This page was generated in 0.02 seconds. Snitz Forums 2000