Ecommerce software home
Shopping Cart Software Forum for Ecommerce Templates
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?



Find us on Facebook

Follow us on Twitter

View our YouTube channel


 All Forums
 Technical
 PHP (Unix / Linux / Apache) versions
 Embedded video stops product creation or cloning
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic   

laleirina
Advanced Member

United Kingdom
139 Posts

Posted - 09/15/2020 :  05:22:26  
Hi!
We have a strange one. We can no longer clone products with an embedded video like this:

<ecttab title="Video">
<iframe width="560" height="315" src="https://www.youtube.com/embed/ZhZYZCWRn58" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

If we do, we get a 403 Forbidden error and that's all.

If you try to create a new product with the same video embedded, it also rejects the creation with the same error.

Is there something in the embedding text which can't be written to the database? We are stumped.

Phil
ECT Moderator

United Kingdom
7115 Posts

Posted - 09/15/2020 :  06:24:46  
Hi Irina
I've just tried adding that as a test product on my site and didn't have any problem, so it maybe worth having a look in your server error logs to give you some clue as to what's going on perhaps?



* Database Migrations and Conversions*
* ASP to PHP Cart Conversions*

*Contact Us*
*Buy The PHP Capture Card Plugin*
*Rate Our Services/View Our Feedback*

ITZAP
Ecommerce Template Expert

Australia
841 Posts

Pre-sales questions only
(More Details...)

Posted - 09/16/2020 :  00:16:49  
I would bet $ that your "403 Forbidden Error" is being triggered by the "ModSecurity" module in cPanel. To test this, follow these steps:

1) Login to cPanel, scroll down to the SECURITY section, click the ModSecurity icon and then the "Disable" button.
2) Now Login to your Ecommerce Templates Admin Panel and once again [C]lone the product with the embedded YouTube Video code snippet.
3) Submit and see if the new product record is Saved successfully ... without any 403 Forbidden Error ... and if so, now you know for sure what the problem is.
4) Either way, next go back to cPanel and re-enable ModSecurity, because it is not desirable to leave this off.

Now it is time to contact your Web Host.
Explain what is happening and ask that they enter an exception into the ModSecurity configuration to allow embedded YouTube Video code snippets to pass without triggering a "403 Forbidden Error".

I have seen this happen before and (in my case at least) the Web Hosting techs fix it in a jiffy.

Gary
[img]https://itzap.com.au/pics/logo/itzap-website-design-works-mini-logo.png[/img]

laleirina
Advanced Member

United Kingdom
139 Posts

Posted - 09/18/2020 :  04:25:04  
Thank you both for your answers.

Phil, we don't have access to the server error logs. I can ask our hosting provider if there is a reason why the database server won't accept embedded videos though.

ITZAP, we don't have ModSecurity in Cpanel. Here is what we do have:



I suspect that our hosting provider have set something in MySql to stop people from linking to videos on public servers. I can ask them.

Thanks!

Steved
Ecommerce Template Expert

United Kingdom
824 Posts

Posted - 09/18/2020 :  05:03:38  
Hi Irina,

Sometimes your host doesn't give you access to mod security in cpanel.

I would definately ask them to check mod security rules to see if they are being triggered as I think Gary is probably correct about this.

Steve
   Topic   
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Shopping Cart Software Forum for Ecommerce Templates © 2002-2019 ecommercetemplates.com
This page was generated in 0.03 seconds. Snitz Forums 2000